Crear una base de datos de MariaDB para Wordpress

Foro sobre el CMS WordPress
Responder
gbeltran
Mensajes: 184
Registrado: 13 May 2023, 01:15
Ubicación: Valencia - España
Contactar:

Crear una base de datos de MariaDB para Wordpress

Mensaje por gbeltran »

Desde la línea de comandos, en Debin 12 (Linux), para un servidor Apache en local:

Accediendo:

Código: Seleccionar todo

sudo mariadb -u root -p

Código: Seleccionar todo

[b]Creando la base de datos wordpress (por ejemplo, wordpress):[/b]
[code]CREATE DATABASE wordpress;
Dando permisos:
MariaDB [(none)]> GRANT ALL PRIVILEGES ON wordpress.* TO 'wordpress'@'localhost' IDENTIFIED BY 'contraseña';
Query OK, 0 rows affected (0,036 sec)

MariaDB [(none)]> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0,001 sec)

MariaDB [(none)]> EXIT
Bye
guillermo@equipo:~$ [/code]

Funciona!

NOTA: Por supuesto, hay que modificar la configuración del archivo wp-config.php cpn los valores correctos de base de datos, usuario y contraseña.
wordpress.jpg
Enlaces útiles (aunque he utilizado otro para instalar WordPress en el servidor local de Apache en Debian 12, ya comentaré):
- https://wiki.alpinelinux.org/wiki/WordPress

INSTRUCCIONES:
- Descargar wordpress desde Linux: https://chachocool.com/como-instalar-wo ... -en-linux/

Código: Seleccionar todo

wget https://es.wordpress.org/latest-es_ES.tar.gz

Código: Seleccionar todo

sudo su
mkdir wordpress
sudo chown -R $USER:www-data /var/www/html/wordpress/
sudo chmod -R g+w /var/www/html/wordpress/
Crear un directorio virtual en Apache y darle permisos. en breve, que me tengo que ir...
Última edición por gbeltran el 23 Feb 2024, 21:36, editado 6 veces en total.
gbeltran
Mensajes: 184
Registrado: 13 May 2023, 01:15
Ubicación: Valencia - España
Contactar:

Re: Crear una base de datos de MariaDB para Wordpress

Mensaje por gbeltran »

Tras haber instalado WordPress, tengo un error de permisos a la hora de instalar y desinstalar plugins: el sistema intenta conectar por FTP o SFTP, sin éxito. La solución:
You wouldn't get the FTP message if you had write permissions set on your plugins folders in wp-content –
Jeff Wooden
Jan 23, 2014 at 18:24
6
@JefferyAWooden The following seems to solve my issue:

Código: Seleccionar todo

sudo adduser <username> www-data 
sudo chown -R www-data:www-data /var/www 
sudo chmod -R g+rw /var/www
Fuente: https://stackoverflow.com/questions/213 ... st-solutio
gbeltran
Mensajes: 184
Registrado: 13 May 2023, 01:15
Ubicación: Valencia - España
Contactar:

(Enlaces permanentes en WordPress) Re: Crear una base de datos de MariaDB para Wordpress

Mensaje por gbeltran »

Ahora faltará crear o modificar el archivo .htaccess para poder cambiar los enlaces permanentes a 'seo-friendly'. Reportaré...

Ver esto sobre los permisos de ficheros en WordPress: https://codex.wordpress.org/es:Modifica ... e_ficheros.

Y esto: https://es.wordpress.org/support/topic/ ... funcionan/ que está basado en esto (módulo Rewrite inactivo en Apache): https://juliorestrepo.wordpress.com/202 ... mment-5834

Voy a probarlo y reporto...

SOLUCIONADO!

Hay que modificar el archivo de configuración del servidor Apache y luego reiniciar el servidor:

Código: Seleccionar todo

root@equipo:~# nano /etc/apache2/apache2.conf
root@equipo:~# systemctl restart apache2
configuracion_apache.jpg
configuracion_apache.jpg (101.59 KiB) Visto 157 veces
Y cambiar el valor AllowOverride None a All en /var/www/:

Código: Seleccionar todo

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>


Con ello, ya podremos utilizar los enlaces permanentes seo-friendly en nuestro WordPress.
Responder